#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "#include.+(?:<|\")(.+)(?:>|\")(?![^*\/]*(?:\*+(?!\/)[^*\/]*|\/+(?!\*)[^*\/]*)*\*\/)"
Local $sString = "an ad" & @CRLF & _
"nn/* k" & @CRLF & _
"as fgj*\ vc" & @CRLF & _
"" & @CRLF & _
"*/" & @CRLF & _
"" & @CRLF & _
"#include <stuffh>" & @CRLF & _
"#include "stuff.h"" & @CRLF & _
"#include /*"stufuf"*/ "stuff.h"" & @CRLF & _
"" & @CRLF & _
"#include /*"stufuf"*/ <stuff.h>" & @CRLF & _
"#include <stuff.h> //sufff" & @CRLF & _
"#include "stuff.h" //stufffd" & @CRLF & _
"/* dsfas;dlf */" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"/* " & @CRLF & _
"#include <stuff.h>" & @CRLF & _
"#include "stuff.h"" & @CRLF & _
"#include "stuff.h"" & @CRLF & _
"#include <stuff.h>" & @CRLF & _
"#include <stuff.h> //sufff" & @CRLF & _
"#include "stuff.h" //stufffd" & @CRLF & _
"" & @CRLF & _
"(#include.+<(.+)>|#include.+"(.+)")" & @CRLF & _
"*/" & @CRLF & _
"#include "stuff"" & @CRLF & _
"#include <stuffh>" & @CRLF & _
"#include "stuff.h"" & @CRLF & _
"#include /*"stufuf"*/ "stuff.h"" & @CRLF & _
"" & @CRLF & _
"#include /*"stufuf"*/ <stuff.h>" & @CRLF & _
"#include <stuff.h> //sufff" & @CRLF & _
"#include "stuff.h" //stufffd" & @CRLF & _
"#ifndef "HEad"" & @CRLF & _
"#include/*" & @CRLF & _
"gfd" & @CRLF & _
"*/ "stuff"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")