using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#include.+(?:<|\"")(.+)(?:>|\"")(?![^*\/]*(?:\*+(?!\/)[^*\/]*|\/+(?!\*)[^*\/]*)*\*\/)";
string input = @"an ad
nn/* k
as fgj*\ vc
*/
#include <stuffh>
#include ""stuff.h""
#include /*""stufuf""*/ ""stuff.h""
#include /*""stufuf""*/ <stuff.h>
#include <stuff.h> //sufff
#include ""stuff.h"" //stufffd
/* dsfas;dlf */
/*
#include <stuff.h>
#include ""stuff.h""
#include ""stuff.h""
#include <stuff.h>
#include <stuff.h> //sufff
#include ""stuff.h"" //stufffd
(#include.+<(.+)>|#include.+""(.+)"")
*/
#include ""stuff""
#include <stuffh>
#include ""stuff.h""
#include /*""stufuf""*/ ""stuff.h""
#include /*""stufuf""*/ <stuff.h>
#include <stuff.h> //sufff
#include ""stuff.h"" //stufffd
#ifndef ""HEad""
#include/*
gfd
*/ ""stuff""
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}