# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"#include.+(?:<|\")(.+)(?:>|\")(?![^*\/]*(?:\*+(?!\/)[^*\/]*|\/+(?!\*)[^*\/]*)*\*\/)"
test_str = ("an ad\n"
"nn/* k\n"
"as fgj*\\ vc\n\n"
"*/\n\n"
"#include <stuffh>\n"
"#include \"stuff.h\"\n"
"#include /*\"stufuf\"*/ \"stuff.h\"\n\n"
"#include /*\"stufuf\"*/ <stuff.h>\n"
"#include <stuff.h> //sufff\n"
"#include \"stuff.h\" //stufffd\n"
"/* dsfas;dlf */\n\n\n"
"/* \n"
"#include <stuff.h>\n"
"#include \"stuff.h\"\n"
"#include \"stuff.h\"\n"
"#include <stuff.h>\n"
"#include <stuff.h> //sufff\n"
"#include \"stuff.h\" //stufffd\n\n"
"(#include.+<(.+)>|#include.+\"(.+)\")\n"
"*/\n"
"#include \"stuff\"\n"
"#include <stuffh>\n"
"#include \"stuff.h\"\n"
"#include /*\"stufuf\"*/ \"stuff.h\"\n\n"
"#include /*\"stufuf\"*/ <stuff.h>\n"
"#include <stuff.h> //sufff\n"
"#include \"stuff.h\" //stufffd\n"
"#ifndef \"HEad\"\n"
"#include/*\n"
"gfd\n"
"*/ \"stuff\"\n\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.