$re = '/#include.+(?:<|\")(.+)(?:>|\")(?![^*\/]*(?:\*+(?!\/)[^*\/]*|\/+(?!\*)[^*\/]*)*\*\/)/';
$str = 'an ad
nn/* k
as fgj*\\ vc
*/
#include <stuffh>
#include "stuff.h"
#include /*"stufuf"*/ "stuff.h"
#include /*"stufuf"*/ <stuff.h>
#include <stuff.h> //sufff
#include "stuff.h" //stufffd
/* dsfas;dlf */
/*
#include <stuff.h>
#include "stuff.h"
#include "stuff.h"
#include <stuff.h>
#include <stuff.h> //sufff
#include "stuff.h" //stufffd
(#include.+<(.+)>|#include.+"(.+)")
*/
#include "stuff"
#include <stuffh>
#include "stuff.h"
#include /*"stufuf"*/ "stuff.h"
#include /*"stufuf"*/ <stuff.h>
#include <stuff.h> //sufff
#include "stuff.h" //stufffd
#ifndef "HEad"
#include/*
gfd
*/ "stuff"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);