import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[ |]*(\\w+)\\s*(>?=|<)\\s*([^:\\n]+)(?:\\s*:\\s*([^(]+))?.*$";
final String string = "| | | | featureB >= 16104.33 : 18873.52 (1/0)\n\n"
+ "| featureA >= 17980.32\n\n"
+ "featureC = ABC BLAH BLAH blA'H $blah 4/ blah blah";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}