re = /^[ |]*(\w+)\s*(>?=|<)\s*([^:\n]+)(?:\s*:\s*([^(]+))?.*$/m
str = '| | | | featureB >= 16104.33 : 18873.52 (1/0)
| featureA >= 17980.32
featureC = ABC BLAH BLAH blA\'H $blah 4/ blah blah'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end