const regex = /^[ |]*(\w+)\s*(>?=|<)\s*([^:\n]+)(?:\s*:\s*([^(]+))?.*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[ |]*(\\w+)\\s*(>?=|<)\\s*([^:\\n]+)(?:\\s*:\\s*([^(]+))?.*$', 'gm')
const str = `| | | | featureB >= 16104.33 : 18873.52 (1/0)
| featureA >= 17980.32
featureC = ABC BLAH BLAH blA'H \$blah 4/ blah blah`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}