$re = '/^[ |]*(\w+)\s*(>?=|<)\s*([^:\n]+)(?:\s*:\s*([^(]+))?.*$/m';
$str = '| | | | featureB >= 16104.33 : 18873.52 (1/0)
| featureA >= 17980.32
featureC = ABC BLAH BLAH blA\'H $blah 4/ blah blah';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);