#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(%\d*[ctYymd]+|\$\d+|.+?(?=%\d*[ctYymd]|\$\d|$))"
Local $sString = "Badstring%02xWrongLetterX" & @CRLF & _
"%03c_Ball0n%02c$1%03d_Ball0n%02d$1" & @CRLF & _
"%03c_Ball0n%02d-hansaBallon$1" & @CRLF & _
"%3c_Ball0n%2t%02d" & @CRLF & _
"%c_foo%Y-%m-%d-bardoo" & @CRLF & _
"Ball0n%02dHamburg%d"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")