use strict;
my $str = 'Badstring%02xWrongLetterX
%03c_Ball0n%02c$1%03d_Ball0n%02d$1
%03c_Ball0n%02d-hansaBallon$1
%3c_Ball0n%2t%02d
%c_foo%Y-%m-%d-bardoo
Ball0n%02dHamburg%d';
my $regex = qr/(%\d*[ctYymd]+|\$\d+|.+?(?=%\d*[ctYymd]|\$\d|$))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}