using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(%\d*[ctYymd]+|\$\d+|.+?(?=%\d*[ctYymd]|\$\d|$))";
string input = @"Badstring%02xWrongLetterX
%03c_Ball0n%02c$1%03d_Ball0n%02d$1
%03c_Ball0n%02d-hansaBallon$1
%3c_Ball0n%2t%02d
%c_foo%Y-%m-%d-bardoo
Ball0n%02dHamburg%d";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}