re = /(%\d*[ctYymd]+|\$\d+|.+?(?=%\d*[ctYymd]|\$\d|$))/m
str = 'Badstring%02xWrongLetterX
%03c_Ball0n%02c$1%03d_Ball0n%02d$1
%03c_Ball0n%02d-hansaBallon$1
%3c_Ball0n%2t%02d
%c_foo%Y-%m-%d-bardoo
Ball0n%02dHamburg%d'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end