#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)SV-14-[^_]*_S[12]"
Local $sString = "SV-14-001_S1" & @CRLF & _
"SV-14-001_S2" & @CRLF & _
"SV-14-002_S1" & @CRLF & _
"SV-14-001_S2" & @CRLF & _
"SV-14-003_S1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")