// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)SV-14-[^_]*_S[12]").unwrap();
let string = "SV-14-001_S1
SV-14-001_S2
SV-14-002_S1
SV-14-001_S2
SV-14-003_S1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}