use strict;
my $str = 'SV-14-001_S1
SV-14-001_S2
SV-14-002_S1
SV-14-001_S2
SV-14-003_S1';
my $regex = qr/SV-14-[^_]*_S[12]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}