$re = '/SV-14-[^_]*_S[12]/m';
$str = 'SV-14-001_S1
SV-14-001_S2
SV-14-002_S1
SV-14-001_S2
SV-14-003_S1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);