import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([1-9](?:\\s*[0-9]){3})\\s?([A-Z])[a-z]*\\s*([A-Z])[a-z]*";
final String string = "1 2 3 4 Alpha Bravo\n"
+ "1234 Alpha Bravo";
final String subst = "$1$2$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}