use strict;
my $str = '1 2 3 4 Alpha Bravo
1234 Alpha Bravo';
my $regex = qr/([1-9](?:\s*[0-9]){3})\s?([A-Z])[a-z]*\s*([A-Z])[a-z]*/mip;
my $subst = '$1$2$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";