re = /([1-9](?:\s*[0-9]){3})\s?([A-Z])[a-z]*\s*([A-Z])[a-z]*/mi
str = '1 2 3 4 Alpha Bravo
1234 Alpha Bravo'
subst = '$1$2$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result