const regex = new RegExp('([1-9](?:\\s*[0-9]){3})\\s?([A-Z])[a-z]*\\s*([A-Z])[a-z]*', 'mig')
const str = `1 2 3 4 Alpha Bravo
1234 Alpha Bravo`;
const subst = `$1$2$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);