using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((bool|byte|short|int|long|float|double|array|box)(\[((.*,)*.*)\])?) ([A-Za-z_][A-Za-z_0-9.]*)";
string input = @"box[int a, int b] c, bool f";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}