// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((bool|byte|short|int|long|float|double|array|box)(\[((.*,)*.*)\])?) ([A-Za-z_][A-Za-z_0-9.]*)").unwrap();
let string = "box[int a, int b] c, bool f";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}