re = /((bool|byte|short|int|long|float|double|array|box)(\[((.*,)*.*)\])?) ([A-Za-z_][A-Za-z_0-9.]*)/m
str = 'box[int a, int b] c, bool f'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end