const regex = /[ \t]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[ \\t]+', 'g')
const str = `database system,query optimization,semantic transformation basic operation crucial prerequisite fast implementation relational calculus representation wide variety database machine level query evaluation centralized database system alternative access plan generalized database management system processing unanticipated query query optimization issue heuristic algorithm distributed database general query evaluation procedure efficient method query evaluation algorithm `;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);