$re = '/[ \t]+/';
$str = 'database system,query optimization,semantic transformation basic operation crucial prerequisite fast implementation relational calculus representation wide variety database machine level query evaluation centralized database system alternative access plan generalized database management system processing unanticipated query query optimization issue heuristic algorithm distributed database general query evaluation procedure efficient method query evaluation algorithm ';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;