import Foundation
let pattern = #"[ \t]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"database system,query optimization,semantic transformation basic operation crucial prerequisite fast implementation relational calculus representation wide variety database machine level query evaluation centralized database system alternative access plan generalized database management system processing unanticipated query query optimization issue heuristic algorithm distributed database general query evaluation procedure efficient method query evaluation algorithm "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)