package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\(([^\)]+)\)$`)
var str = []byte(`1 (Male 40-44)`)
var substitution = []byte("Male 40-44")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}