const regex = /\(([^\)]+)\)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\(([^\\)]+)\\)$', '')
const str = `1 (Male 40-44)`;
const subst = `Male 40-44`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);