using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\s*[><]\s*\d+([.]\d+)?|\d+([.]\d+)?\s*(-?\s*\d+([.]\d+)?\s*)?)$";
string input = @"2.5
1-15.5
>10
>12.54
<75
# Works also on
>46
12 -15.2
>14.3
5 - 10
1.5 - 10.3
< 10
# refuse invalid
< 10.2.
1 - ..
< 10 > 10
1- 1 -1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}