use strict;
my $str = '2.5
1-15.5
>10
>12.54
<75
# Works also on
>46
12 -15.2
>14.3
5 - 10
1.5 - 10.3
< 10
# refuse invalid
< 10.2.
1 - ..
< 10 > 10
1- 1 -1';
my $regex = qr/^(\s*[><]\s*\d+([.]\d+)?|\d+([.]\d+)?\s*(-?\s*\d+([.]\d+)?\s*)?)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}