# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\s*[><]\s*\d+([.]\d+)?|\d+([.]\d+)?\s*(-?\s*\d+([.]\d+)?\s*)?)$"
test_str = ("2.5\n"
"1-15.5\n"
">10\n"
">12.54\n"
"<75\n\n"
"# Works also on\n\n"
">46\n\n"
"12 -15.2\n"
">14.3\n"
"5 - 10\n\n"
"1.5 - 10.3\n"
"< 10\n\n"
"# refuse invalid\n"
"< 10.2.\n\n"
"1 - ..\n"
"< 10 > 10\n\n"
"1- 1 -1")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.