re = /^(\s*[><]\s*\d+([.]\d+)?|\d+([.]\d+)?\s*(-?\s*\d+([.]\d+)?\s*)?)$/m
str = '2.5
1-15.5
>10
>12.54
<75
# Works also on
>46
12 -15.2
>14.3
5 - 10
1.5 - 10.3
< 10
# refuse invalid
< 10.2.
1 - ..
< 10 > 10
1- 1 -1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end