#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^([^_]*_[^_]*).*"
Local $sString = "1-343-43Hello_2_323.14_fdh-99H"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)