$re = '/^([^_]*_[^_]*).*/';
$str = '1-343-43Hello_2_323.14_fdh-99H';
$subst = "$1";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;