import re
regex = re.compile(r"^([^_]*_[^_]*).*")
test_str = "1-343-43Hello_2_323.14_fdh-99H"
subst = "$1"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)