#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)(\b\w.{3,49})\1{4}"
Local $sString = "I like fish very much I like fish very much I like fish very much" & @CRLF & _
"Marshmallows are yummy. Marshmallows are yummy. Marshmallows are yummy." & @CRLF & _
"" & @CRLF & _
"But this would not be:" & @CRLF & _
"" & @CRLF & _
"I like fish very much I like fish very much I like fish very much I like fish very much I like fish very much I like fish very much I like fish very much I like fish very much" & @CRLF & _
"" & @CRLF & _
"nor this:" & @CRLF & _
"" & @CRLF & _
"Marshmallows are yummy. Marshmallows are yummy. Marshmallows are yummy. Marshmallows are yummy. Marshmallows are yummy. Marshmallows are yummy. Marshmallows are yummy. Marshmallows are yummy. Marshmallows are yummy. Marshmallows are yummy." & @CRLF & _
"" & @CRLF & _
"Ideally, it would also catch it even if it was entered like this:" & @CRLF & _
"" & @CRLF & _
"I like fish very much" & @CRLF & _
"I like fish very much" & @CRLF & _
"I like fish very much" & @CRLF & _
"I like fish very much" & @CRLF & _
"I like fish very much" & @CRLF & _
"I like fish very much"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")