using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\b\w.{3,49})\1{4}";
string input = @"I like fish very much I like fish very much I like fish very much
Marshmallows are yummy. Marshmallows are yummy. Marshmallows are yummy.
But this would not be:
I like fish very much I like fish very much I like fish very much I like fish very much I like fish very much I like fish very much I like fish very much I like fish very much
nor this:
Marshmallows are yummy. Marshmallows are yummy. Marshmallows are yummy. Marshmallows are yummy. Marshmallows are yummy. Marshmallows are yummy. Marshmallows are yummy. Marshmallows are yummy. Marshmallows are yummy. Marshmallows are yummy.
Ideally, it would also catch it even if it was entered like this:
I like fish very much
I like fish very much
I like fish very much
I like fish very much
I like fish very much
I like fish very much";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}