# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\b\w.{3,49})\1{4}"
test_str = ("I like fish very much I like fish very much I like fish very much\n"
"Marshmallows are yummy. Marshmallows are yummy. Marshmallows are yummy.\n\n"
"But this would not be:\n\n"
"I like fish very much I like fish very much I like fish very much I like fish very much I like fish very much I like fish very much I like fish very much I like fish very much\n\n"
"nor this:\n\n"
"Marshmallows are yummy. Marshmallows are yummy. Marshmallows are yummy. Marshmallows are yummy. Marshmallows are yummy. Marshmallows are yummy. Marshmallows are yummy. Marshmallows are yummy. Marshmallows are yummy. Marshmallows are yummy.\n\n"
"Ideally, it would also catch it even if it was entered like this:\n\n"
"I like fish very much\n"
"I like fish very much\n"
"I like fish very much\n"
"I like fish very much\n"
"I like fish very much\n"
"I like fish very much")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.