use strict;
my $str = 'I like fish very much I like fish very much I like fish very much
Marshmallows are yummy. Marshmallows are yummy. Marshmallows are yummy.
But this would not be:
I like fish very much I like fish very much I like fish very much I like fish very much I like fish very much I like fish very much I like fish very much I like fish very much
nor this:
Marshmallows are yummy. Marshmallows are yummy. Marshmallows are yummy. Marshmallows are yummy. Marshmallows are yummy. Marshmallows are yummy. Marshmallows are yummy. Marshmallows are yummy. Marshmallows are yummy. Marshmallows are yummy.
Ideally, it would also catch it even if it was entered like this:
I like fish very much
I like fish very much
I like fish very much
I like fish very much
I like fish very much
I like fish very much';
my $regex = qr/(\b\w.{3,49})\1{4}/msp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}