#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:(?<!\\){((?:(?:red|blue|black)\.?)+)(?<!\.)\s((?:(?:[^{](?!{|})|\\{|\\})+.)?))|((?<!\\)})"
Local $sString = " {red.blue.black {red \{{texxt\{text} text}213" & @CRLF & _
"" & @CRLF & _
" {red.blue.black. \{text \{text}text{text} text" & @CRLF & _
" {red.blue.black text \{texttext{text\} text" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" {red.blue.black text \{texxt\}text} text" & @CRLF & _
" {red.blue.black text \{text{ text{text} text" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{red.blue.ggg text \{text}text{text} text" & @CRLF & _
" {red.blue.ggg text \{text}text{text} text" & @CRLF & _
"\{red.blue.ggg text \{text}text{text} text" & @CRLF & _
"" & @CRLF & _
"{red text \{text}text{text} text" & @CRLF & _
" {red {red das}text \{text\}text{text} text" & @CRLF & _
"\{red text \{text}text{text} text" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"\{red.blue.black text \{text}text{text} text" & @CRLF & _
"" & @CRLF & _
"{red.blue.ggg text \{text}text{text} text" & @CRLF & _
" {red.blue.ggg text \{text}text{text} text" & @CRLF & _
"\{red.blue.ggg text \{text}text{text} text" & @CRLF & _
"" & @CRLF & _
"{red text \{text}text{text} text" & @CRLF & _
" {red text \{text}text{text} text" & @CRLF & _
"\{red text \{text}text{text} text" & @CRLF & _
"" & @CRLF & _
"{red.blue.black text \{text}text{text} text" & @CRLF & _
" {red.blue.black text \{text\}text{text} text" & @CRLF & _
"\{red.blue.black text \{text}text{text} text"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")