re = /(?:(?<!\\){((?:(?:red|blue|black)\.?)+)(?<!\.)\s((?:(?:[^{](?!{|})|\\{|\\})+.)?))|((?<!\\)})/
str = ' {red.blue.black {red \\{{texxt\\{text} text}213
{red.blue.black. \\{text \\{text}text{text} text
{red.blue.black text \\{texttext{text\\} text
{red.blue.black text \\{texxt\\}text} text
{red.blue.black text \\{text{ text{text} text
{red.blue.ggg text \\{text}text{text} text
{red.blue.ggg text \\{text}text{text} text
\\{red.blue.ggg text \\{text}text{text} text
{red text \\{text}text{text} text
{red {red das}text \\{text\\}text{text} text
\\{red text \\{text}text{text} text
\\{red.blue.black text \\{text}text{text} text
{red.blue.ggg text \\{text}text{text} text
{red.blue.ggg text \\{text}text{text} text
\\{red.blue.ggg text \\{text}text{text} text
{red text \\{text}text{text} text
{red text \\{text}text{text} text
\\{red text \\{text}text{text} text
{red.blue.black text \\{text}text{text} text
{red.blue.black text \\{text\\}text{text} text
\\{red.blue.black text \\{text}text{text} text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end