import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?<!\\\\)\\{((?:(?:red|blue|black)\\.?)+)(?<!\\.)\\s((?:(?:[^\\{](?!\\{|\\})|\\\\\\{|\\\\\\})+.)?))|((?<!\\\\)\\})";
final String string = " {red.blue.black {red \\{{texxt\\{text} text}213\n\n"
+ " {red.blue.black. \\{text \\{text}text{text} text\n"
+ " {red.blue.black text \\{texttext{text\\} text\n\n\n"
+ " {red.blue.black text \\{texxt\\}text} text\n"
+ " {red.blue.black text \\{text{ text{text} text\n\n\n\n"
+ "{red.blue.ggg text \\{text}text{text} text\n"
+ " {red.blue.ggg text \\{text}text{text} text\n"
+ "\\{red.blue.ggg text \\{text}text{text} text\n\n"
+ "{red text \\{text}text{text} text\n"
+ " {red {red das}text \\{text\\}text{text} text\n"
+ "\\{red text \\{text}text{text} text\n\n\n"
+ "\\{red.blue.black text \\{text}text{text} text\n\n"
+ "{red.blue.ggg text \\{text}text{text} text\n"
+ " {red.blue.ggg text \\{text}text{text} text\n"
+ "\\{red.blue.ggg text \\{text}text{text} text\n\n"
+ "{red text \\{text}text{text} text\n"
+ " {red text \\{text}text{text} text\n"
+ "\\{red text \\{text}text{text} text\n\n"
+ "{red.blue.black text \\{text}text{text} text\n"
+ " {red.blue.black text \\{text\\}text{text} text\n"
+ "\\{red.blue.black text \\{text}text{text} text";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}