const regex = /(?:(?<!\\){((?:(?:red|blue|black)\.?)+)(?<!\.)\s((?:(?:[^{](?!{|})|\\{|\\})+.)?))|((?<!\\)})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?<!\\\\){((?:(?:red|blue|black)\\.?)+)(?<!\\.)\\s((?:(?:[^{](?!{|})|\\\\{|\\\\})+.)?))|((?<!\\\\)})', 'g')
const str = ` {red.blue.black {red \\{{texxt\\{text} text}213
{red.blue.black. \\{text \\{text}text{text} text
{red.blue.black text \\{texttext{text\\} text
{red.blue.black text \\{texxt\\}text} text
{red.blue.black text \\{text{ text{text} text
{red.blue.ggg text \\{text}text{text} text
{red.blue.ggg text \\{text}text{text} text
\\{red.blue.ggg text \\{text}text{text} text
{red text \\{text}text{text} text
{red {red das}text \\{text\\}text{text} text
\\{red text \\{text}text{text} text
\\{red.blue.black text \\{text}text{text} text
{red.blue.ggg text \\{text}text{text} text
{red.blue.ggg text \\{text}text{text} text
\\{red.blue.ggg text \\{text}text{text} text
{red text \\{text}text{text} text
{red text \\{text}text{text} text
\\{red text \\{text}text{text} text
{red.blue.black text \\{text}text{text} text
{red.blue.black text \\{text\\}text{text} text
\\{red.blue.black text \\{text}text{text} text`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}