#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([a-zA-Z0-9\_]*)\:\s?([A-Za-z0-9\"\']*)"
Local $sString = "classes = {" & @CRLF & _
" Romanian: 1," & @CRLF & _
" English: 2," & @CRLF & _
" French: 3," & @CRLF & _
" German: 4," & @CRLF & _
" Latin: 5," & @CRLF & _
" Math: 6," & @CRLF & _
" Physics: 7," & @CRLF & _
" Chemistry: 8," & @CRLF & _
" Biology: 9," & @CRLF & _
" History: 10," & @CRLF & _
" Geography: 11," & @CRLF & _
" Social: 12," & @CRLF & _
" Religion: 13," & @CRLF & _
" Music: 14," & @CRLF & _
" Arts: 15," & @CRLF & _
" Sports: 16," & @CRLF & _
" ComputerScience: 17," & @CRLF & _
" IT: 18" & @CRLF & _
"};"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")