package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-zA-Z0-9\_]*)\:\s?([A-Za-z0-9\"\']*)`)
var str = `classes = {
Romanian: 1,
English: 2,
French: 3,
German: 4,
Latin: 5,
Math: 6,
Physics: 7,
Chemistry: 8,
Biology: 9,
History: 10,
Geography: 11,
Social: 12,
Religion: 13,
Music: 14,
Arts: 15,
Sports: 16,
ComputerScience: 17,
IT: 18
};`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}