#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^0$|^[1-9](?:\.[0-9]{1,2})?$|^10(?:\.00?)?$"
Local $sString = "10.0" & @CRLF & _
"10.00" & @CRLF & _
"9.99" & @CRLF & _
"1.12" & @CRLF & _
"2.34" & @CRLF & _
"11.1" & @CRLF & _
"1" & @CRLF & _
"2" & @CRLF & _
"3" & @CRLF & _
"4" & @CRLF & _
"5" & @CRLF & _
"6" & @CRLF & _
"7" & @CRLF & _
"8" & @CRLF & _
"9" & @CRLF & _
"1.1" & @CRLF & _
"2.12" & @CRLF & _
"3.32" & @CRLF & _
"4.45" & @CRLF & _
"5.67" & @CRLF & _
"6.98" & @CRLF & _
"7.12" & @CRLF & _
"8.3" & @CRLF & _
"9.56" & @CRLF & _
"10" & @CRLF & _
"1.1234"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")