import Foundation
let pattern = #"^0$|^[1-9](?:\.[0-9]{1,2})?$|^10(?:\.00?)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
10.0
10.00
9.99
1.12
2.34
11.1
1
2
3
4
5
6
7
8
9
1.1
2.12
3.32
4.45
5.67
6.98
7.12
8.3
9.56
10
1.1234
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)