// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^0$|^[1-9](?:\.[0-9]{1,2})?$|^10(?:\.00?)?$").unwrap();
let string = "10.0
10.00
9.99
1.12
2.34
11.1
1
2
3
4
5
6
7
8
9
1.1
2.12
3.32
4.45
5.67
6.98
7.12
8.3
9.56
10
1.1234";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}