# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^0$|^[1-9](?:\.[0-9]{1,2})?$|^10(?:\.00?)?$"
test_str = ("10.0\n"
"10.00\n"
"9.99\n"
"1.12\n"
"2.34\n"
"11.1\n"
"1\n"
"2\n"
"3\n"
"4\n"
"5\n"
"6\n"
"7\n"
"8\n"
"9\n"
"1.1\n"
"2.12\n"
"3.32\n"
"4.45\n"
"5.67\n"
"6.98\n"
"7.12\n"
"8.3\n"
"9.56\n"
"10\n"
"1.1234")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.