#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)([-*]*\s*\b(edit|update).*\b(\s*#?[0-9]+)?\s*:+\s*[-*]*\s*|[-*]+\s*\b(edit|update).*\b(\s*#?[0-9]+)?\s*:*\s*[-*]+)\s*"
Local $sString = "UPDATE: changed the example to show use," & @CRLF & _
"" & @CRLF & _
"Edit: Something different" & @CRLF & _
"" & @CRLF & _
"**EDIT** I really mean this one..." & @CRLF & _
"" & @CRLF & _
"Edit #2: " & @CRLF & _
"" & @CRLF & _
"I'm going to edit my question. Better not match any of this update here." & @CRLF & _
"" & @CRLF & _
"Edit the file to..." & @CRLF & _
"" & @CRLF & _
"Update for anyone who cares:" & @CRLF & _
"" & @CRLF & _
"Update for nobody." & @CRLF & _
"" & @CRLF & _
"**Edit: More precise explanation:**" & @CRLF & _
"" & @CRLF & _
"***editprofile.js***" & @CRLF & _
"" & @CRLF & _
"-- Edit --"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")